1.52 not working for me

May 7, 2011 at 5:11 PM

Hi, been using Rehost Image for some time now and couldn't live without it! unfortunately though after updating to the new version (1.52) the resource seems to be not working at all. There is no option present in the browser right click menu to rehost an image, as was there previously with older versions.


I've tried this with the older version of Firefox, as well as the newly released version 4, each without success. Reverting to a pre 1.52 version sees everything working normally again however so the issue seems to be unique to the latest build. i'm running W7 x64, and Firefox is installed in the /Program Files (x86) directory.


Any help appreciated.

May 7, 2011 at 5:34 PM
Edited May 7, 2011 at 5:35 PM

Hmm. Try this: go to about:config and search for "rehost". You'll see a bunch of options there. If you have location information you want to save, back it up. Then make sure all of the extensions.rehostimage.___ are defaults or removed (leave the extensions.rehostimage@engy.us settings alone). Close Firefox and reopen, then see if it comes back. If it's still not there, open the error console (Ctrl+Shift+J) and search for an error that looks like it might have come from Rehost Image.

May 7, 2011 at 6:34 PM
Edited May 7, 2011 at 6:43 PM

Thanks for the quick reply. Reset all the relevant entries in the config, as well as checking the error console. No luck I'm afraid. I did however notice that there's an entry in the about:config, that mentions .NET Framework 3.5. Seems that there's some issues with the framework assistant and firefox 4 using oneclick applications. Not sure if that may somehow be relevant?


Edit: may also be relevant; when I open the rehost image options and try to make any changes, pressing "OK" to ext results in this error message. "TypeError: CurrentLocation is null"

May 7, 2011 at 6:46 PM

Solved it! It was due to the "currentlocation is null" error message. I just manually added a location called "1", pressed oK to exit, and now everything is working perfectly. Strange but glad to have it sorted.


Thanks for the help

May 7, 2011 at 8:13 PM

Ahh this was my bad. I moved the locations storage out to sqlite but I forgot to add the default location when creating the DB from scratch. Should be fixed next version.

May 8, 2011 at 5:09 PM

Should be fixed in 1.5.3.